«

»

AMD A10-7850K Performance Optimized Catalyst 14.2 Driver

PAGE INDEX

<< PREVIOUS            NEXT >>

 AMD Catalyst Driver 14.2 Beta Conclusion

When Kaveri was released in January 2014, AMD made a huge deal about it and the new era of heterogeneous compute Kaveri was ushering in. When I first got my hands on Kaveri, I was very impressed by all the information about how much better HSA was going to make the world. When it came down to the actual testing, though, there just wasn’t all that much to get excited about. While Kaveri definitely put up some performance gains when compared with last generation’s APUs, but with all the hype, I was expecting something truly revolutionary.

AMD_Kaveri_HSAWhen AMD released Catalyst 14.1 drivers, I quickly updated to see what kind of improvements had been made. Updated drivers always help with optimizing performance. Unfortunately, 14.1 had a lot of issues. There were performance gains because of the integration of the Mantle API, but there is a reason that Beta drivers are Beta. Catalyst 14.2 was released not too long ago and I was finally able to see the gains I was waiting for.

From the tests, we can see that 14.2 doesn’t do a ton for CPU tasks, but in the GPU arena, the new Beta drivers really shine. Even in games and GPU synthetic benchmarks that don’t use the Mantle API, 14.2 brought significant performance gains, much more on par with what I was hoping to see. In Battlefield 4, using the Mantle API, 14.2 resulted in a performance increase of over 40%.

Beta drivers are in Beta release for a reason, they usually aren’t fully ready for prime time. That was certainly the case with the Catalyst 14.1 Beta release. 14.2 is different, however. It isn’t without its flaws. I am still having trouble running 14.2 on the Gigabyte G1.Sniper A88X motherboard. It runs great on the ASRock F2A88X Extreme6+ and the ASUS A88X-Pro. If you do update the Catalyst 14.2 Beta, make sure you update your BIOS first to the latest version.

The bottom line is this: If you have upgraded to Kaveri, you need Catalyst 14.2 Beta. I would also update to 14.2 if you use an R5, R7, or R9 GPU, especially if you play Battlefield 4.


SKIP TO PAGE:

<< PREVIOUS            NEXT >>

Leave a Reply

Your email address will not be published. Required fields are marked *

CAPTCHA Image

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>